Tag Archives: HP

Installing FreeNAS on a HP Microserver

Another post about my installation experience, mainly so that I can look up what issues I came across if I have to do this again. This is on my HP Gen8 Microserver (by now Gen10 is already out).

My old NAS4Free system couldn’t be updated, at least not without getting the server out of the inaccessible corner where it has served away for the last few years.

Handling snapshots was not easy, so I wanted to update, but thought if the server is out anyway I might as well give FreeNAS a chance. I don’t remember why I decided NAS4FREE is better for my purposes when I installed the server originally and I this time round I didn’t spend much time comparing both systems, so might have picked the less optimal system for my purposes.

FreeNAS or NAS4Free

Followed instructions from http://doc.freenas.org/11/install.html

Had to use sudo to get the iso to the USB stick. Copying took around 2 minutes.

Didn’t work first time round, despite following instructions. Tried again, this time with ejecting the disk  in terminal

diskutil eject /dev/disk6

after dd command. Still no joy.

Tried adding the USB stick after graphical boot screen as described in this forum.

Still doesn’t work.

Tried to boot NAS4FREE from USB stick, also didn’t work.

Tried another computer (maybe computer crazy, virus scanner, …)

Didn’t work from second Mac either

Trying to write iso with Rufus on Windows machine. Writing with windows app recommended in FreeNASdoc outdated (Windows 7). Rufus: Works.

Q: Why does writing the iso not work with new versions of Apple’s disk utility, used to work with old one

FreeNAS doesn’t seem to be able to install FreeNAS either because it was the USB stick the machine booted from or because 8GB is too small. Installing on other USB. Worked.

To my surprise FreeNAS was able to import my old ZFS Volumes/Pool and I even had access to all Snapshots!

Deleting old snapshots is much easier than in my outdated version of NAS4Free, e.g. to save space I only keep snapshots form the first of a month, so I can filter all snapshots where the name does not contain 01- (as in auto-20150901-000000).

Setting up rsync

Created user (Account / Add User) (wheel group)

Configured rsync as described at http://doc.freenas.org/11/tasks.html#rsync-module-mode

Configured Hyperbackup in Synology NAS

HDD standby

Set up  HDD standby:

Storage / View Disks / HDD name / edit

time is in minutes

Services / SMART / Power Mode / Standby (check the drive unless it is in SLEEP or STANDBY mode)

Advertisements

Installing NAS4Free on an HP Gen8 Microserver

2015-07-30 14.32.55 I recently bought a HP Proliant Microserver Gen8. It was < £170 (because I bought it from a Spanish company though Amazon DE, in the UK it was about £15 more at the time), which makes it nearly as cheap as a two bay Synology NAS, but with much better hardware. You got to take care of the software yourself, though.

Came with 2GB RAM, I added another 8GB.
Came with 2GB RAM, I added another 8GB.

I bought mine with the main purpose (for now) of being an rsync server for my Synology NAS. I guess it would be much better to move everything to the HP Microserver, but I don’t have the disk capacity for such a transfer, plus it might be difficult (I haven’t checked) to backup to the Synology NAS because of their restrictive software (I won’t go into more details about all the restrictions I found in the past, many of them don’t seem to make sense). So here’s what I did to install NAS4Free on my HP Gen8 Microserver, and what I did to set it up as an rsync server.

Nice, a USB port on the motherboard.
Nice, a USB port on the motherboard.

1) Download x64 Live USB version

from https://sourceforge.net/projects/nas4free/files/

2) Copy image to USB stick

In OS X’s terminal

diskutil list

Find the USB stick so that you can unmount it …in my case disk2

diskutil unmountDisk /dev/disk2

Copy the image. Writing to rdisk is much faster than writing to disk

sudo dd if=Downloads/NAS4Free-x64-LiveUSB-10.1.0.2.1731.img of=/dev/rdisk2 bs=1m

If you don’t set the block size copying will take much(!) longer.

diskutil eject /dev/disk2

3) Boot Microserver from USB stick

In the Console Menu chose 9) Install/Upgrade from LiveCD/LiveUSB

4) Install the embedded version onto another USB stick

There is the idea that this will wear the USB stick out. It’s the cheapest option for me for now. Good USB sticks cost less then £5 and my system doesn’t seem to use the Swap partition. In the Console Menu under 2) I didn’t use DHCP. I want a fixed address, but want to set it up in NAS4Free, so that I don’t use the same IP in case I boot another OS / ESXi used 192.168.0.15/24 default gateway 192.168.0.1 used Google’s DNS 8.8.8.8 Didn’t configure IPv6

5) Access the web interface

Next I looked at the web interface, in my case at http://192.168.0.15 WebGUI Disks|Management Added my HDD (the plus icon on the right is for adding)

6) Disks|Format

Formatted disk as ZFS

7) Disks|ZFS|Pools|Virtual device

I only have one drive, so I chose Stripe

8) Disks|ZFS|Pools|Management

Added a Pool , Apply The next step didn’t work initially. I think you have to reboot after creating the pool. It did work after I did a reboot. 

9) Disks|ZFS|Datasets|Dataset|Add

Added a dataset where rsync is supposed to go. Enabled compression (hope that’s a good idea)

10) Access|Users|Add

Added a user for the rsync task in the wheel group

11) Services|Rsync|Server|Settings

Enabled this and mapped it to the user created in the previous step

12) Services|Rsync|Server|Modules

Created a module, this will then be shown in the Synology NAS when you set up the rsync backup. Synology backups to the Microserver didn’t work initially when the user field was left empty. It worked after I set userid to root as mentioned at http://forums.nas4free.org/viewtopic.php?f=28&t=5985

13) Set up the Synology NAS

Went to Synology: Backup & Replication Backup Destination – Create Network Backup Destination Backup – Create Backup and set a schedule

Conclusion

I’m just doing my first rsync backup and am getting 50MB/s (400 Mb/s) data transfer rates despite using compression and a long ethernet cable (of poor quality). That’s faster than expected, but I guess the reason it’s not even fast is the Synology station, not NAS4Free on the Gen8 Microserver. I changed power daemon settings in System Advanced, but haven’t tested what difference it actually makes in terms of power use. I also used power saving settings in hdd settings and changed Disks|Management|S.M.A.R.T. Power Mode to standby. Not sure whether I should turn that off, rsync will only need the HDD once a day. After the first backups of the different Synology shares have finished I want to activate Disks|ZFS|Snapshots|Auto Snapshot.