Tag Archives: Gen10

Installing FreeNAS on a HP Microserver

Another post about my installation experience, mainly so that I can look up what issues I came across if I have to do this again. This is on my HP Gen8 Microserver (by now Gen10 is already out).

My old NAS4Free system couldn’t be updated, at least not without getting the server out of the inaccessible corner where it has served away for the last few years.

Handling snapshots was not easy, so I wanted to update, but thought if the server is out anyway I might as well give FreeNAS a chance. I don’t remember why I decided NAS4FREE is better for my purposes when I installed the server originally and I this time round I didn’t spend much time comparing both systems, so might have picked the less optimal system for my purposes.

FreeNAS or NAS4Free

Followed instructions from http://doc.freenas.org/11/install.html

Had to use sudo to get the iso to the USB stick. Copying took around 2 minutes.

Didn’t work first time round, despite following instructions. Tried again, this time with ejecting the disk  in terminal

diskutil eject /dev/disk6

after dd command. Still no joy.

Tried adding the USB stick after graphical boot screen as described in this forum.

Still doesn’t work.

Tried to boot NAS4FREE from USB stick, also didn’t work.

Tried another computer (maybe computer crazy, virus scanner, …)

Didn’t work from second Mac either

Trying to write iso with Rufus on Windows machine. Writing with windows app recommended in FreeNASdoc outdated (Windows 7). Rufus: Works.

Q: Why does writing the iso not work with new versions of Apple’s disk utility, used to work with old one

FreeNAS doesn’t seem to be able to install FreeNAS either because it was the USB stick the machine booted from or because 8GB is too small. Installing on other USB. Worked.

To my surprise FreeNAS was able to import my old ZFS Volumes/Pool and I even had access to all Snapshots!

Deleting old snapshots is much easier than in my outdated version of NAS4Free, e.g. to save space I only keep snapshots form the first of a month, so I can filter all snapshots where the name does not contain 01- (as in auto-20150901-000000).

Setting up rsync

Created user (Account / Add User) (wheel group)

Configured rsync as described at http://doc.freenas.org/11/tasks.html#rsync-module-mode

Configured Hyperbackup in Synology NAS

HDD standby

Set up  HDD standby:

Storage / View Disks / HDD name / edit

time is in minutes

Services / SMART / Power Mode / Standby (check the drive unless it is in SLEEP or STANDBY mode)

Advertisements